New P4 Problems

Joined
Feb 6, 2016
Messages
56
Reaction score
8
Age
73
Location
Adelaide South Australia
Hi , really frustrated with my new P4
Problems are
Linking light blinking red and green, won't link.
Abnormal software message
- IMU NEEDS CALIBRATION
- AVOIDANCE SYSTEM NEEDS CALIBRATION
Both batteries went flat during set up on workbench, one can't be turned off
No image from camera.
Has not yet flown
Am I missing something obvious?
Have been flying P3S for many months with no problems.
Is it a dud?
Any feedback welcome
Cheers
Brian

Sent from my SM-G920I using PhantomPilots mobile app
 
Joined
Mar 14, 2016
Messages
1,022
Reaction score
370
Age
37
Location
Canterbury, CT
Joined
Mar 14, 2016
Messages
1,022
Reaction score
370
Age
37
Location
Canterbury, CT
Hi , really frustrated with my new P4
Problems are
Linking light blinking red and green, won't link.
Abnormal software message
- IMU NEEDS CALIBRATION
- AVOIDANCE SYSTEM NEEDS CALIBRATION
Both batteries went flat during set up on workbench, one can't be turned off
No image from camera.
Has not yet flown
Am I missing something obvious?
Have been flying P3S for many months with no problems.
Is it a dud?
Any feedback welcome
Cheers
Brian

Sent from my SM-G920I using PhantomPilots mobile app
Did you fully charge everything? What lights blink on the p4 batt? 2 middle lights?

Sent from my SM-G900V using PhantomPilots mobile app
 
Phantom Drones from EALLRC.com

New Threads

Members online

Forum statistics

Threads
136,714
Messages
1,413,697
Members
99,376
Latest member
Das Nuvens