Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Mi Pad 2 can't connect

Discussion in 'Phantom 3 Help' started by alwidya, Sep 23, 2016.

  1. alwidya

    Joined:
    Sep 23, 2016
    Messages:
    1
    Likes Received:
    0
    My Mi Pad 2 can't connect to the camera. I tried to activate USB debugging but can't detect the remote controller automatically. I opened the DJI GO, and chose phantom 3 professional but still couldn't connect to the camera. I also already tried to reboot the Mi Pad but nothing change.

    Anyone, if you have similar experience or solution, please let me know.
     
  2. rockydog

    Joined:
    May 25, 2015
    Messages:
    1,218
    Likes Received:
    360
    Location:
    London UK
    iPad 2 doesn't have a fast enough processor to use with DJI GO...you need an iPad Air or later. The iPad Mini 2 is ok.
     
    George McCann likes this.
Loading...
Similar Threads - Pad can't connect Forum Date
Can't connect to iPad DJI Ground Station Jun 21, 2014
Can't get maps to load on an iPad mini 4 with data! Standard/4k Discussion Jun 28, 2017
iPad Air and iPad mini can't see outside General Discussion Feb 4, 2017
iPad Mini 4 For editing and Viewing,So my eight year old Macbook can't handle watching my videos. Phantom 4 Help Feb 3, 2017
Can't log in to ground station on IPAD2 DJI Ground Station Jan 24, 2017