Litchi - Return to home

Joined
Jan 16, 2017
Messages
64
Reaction score
14
Hi, this was my first time using Litchi (Android) and my P3S keep initiating return to home even at various (short) distances even though there are no signal lost condition. Is there any reason why it's behaving like that? Here's the log from healthydrones:

HealthyDrones.com - Innovative flight data analysis that matters

As far as I can see, the signal was good throughout the flight, so I don't understand why it would initiate return to home in seemingly random fashion like that. None of the Go_Home action in that log was initiated by me.

I haven't tried with DJI Go yet after this, so I'm not sure if this issue is specific to Litchi or not
 
Joined
Jan 16, 2017
Messages
64
Reaction score
14
I was trying to fly mission at first but it wouldn't work (waypoint to close error). I didn't know what causing it at the time, so I cancelled mission mode, put Litchi in FPV mode and switch the controller back to P mode
 
Joined
Jun 22, 2016
Messages
1,049
Reaction score
557
Location
Sarasota FloriDuh
Spec. It is complaining about your mode switch, and you had it in 'F' right? I do not use Litchi because I do not trust it, but that is just something personal, I use Ultimate Flight and have not seen anything like your issue. You had a viable mission planned and ready to go?
 
  • Like
Reactions: squid
Joined
Jan 16, 2017
Messages
64
Reaction score
14
Well it went like this, I tried to start a mission, Litchi complained that I'm not in the correct mode. So I switched the controller to F mode and tried to start the mission again. Litchi then complained about waypoint distance too close. I didn't realized what error that was at the time (later on I found out in the mission hub that my first and last waypoints are very close, so that must've what causing the error). Anyway, I tried starting mission a few more times on various distance, thinking that the drone's distance to the waypoint was what causing the error. When that didn't work, I switched back to FPV mode and P mode and fly normally, but as you can see from the log, it kept trying to return to home for some reason
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
6,083
Reaction score
1,325
Age
57
Location
Pacific,NorthWet, 97031
Joined
Jan 16, 2017
Messages
64
Reaction score
14
Mission

Well there's nothing interesting to it really, it's just a test for my first waypoint mission. It's been adjusted so the waypoint distance is not too close.

Does Litchi has some sort of beginner mode? Still puzzled why it kept returning home for no reason like that
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
6,083
Reaction score
1,325
Age
57
Location
Pacific,NorthWet, 97031
I have not looked at any of my missions with HD yet, if there is problem with my mission, the motors don't start.
On an android it is said you need to kill the go-app, even if it is not open.
What activated auto takeoff?

When I see the way point errors, then after those the go-home stuff, to me Litchi saw failure in the settings, we can't run the mission, go-home. I'm guessing. ;)

Rod
 
Joined
Jan 16, 2017
Messages
64
Reaction score
14
The errors on mine is because of the waypoints being too close. I cancelled mission because I didn't know how to fix it at the time. The go home actions all occurred during FPV mode
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
6,083
Reaction score
1,325
Age
57
Location
Pacific,NorthWet, 97031
The errors on mine is because of the waypoints being too close. I cancelled mission because I didn't know how to fix it at the time. The go home actions all occurred during FPV mode
I don't understand, to close to the home point or each other?
You had errors before your way point errors, I don't think that's it, maybe something to do with home point?

Rod
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
6,083
Reaction score
1,325
Age
57
Location
Pacific,NorthWet, 97031
I see, I don't watch much news, and don't have a clue who Spacex is, but I get it now. :)

Rod
 
  • Like
Reactions: DanMan32
Joined
Jan 16, 2017
Messages
64
Reaction score
14
I don't understand, to close to the home point or each other?
You had errors before your way point errors, I don't think that's it, maybe something to do with home point?

Rod
My first and last waypoints are practically on top of each other, I think that's what triggered the error. Anyway, the point is I cancelled the mission and switched back to FPV mode and fly manually afterwards
 
Joined
Jan 16, 2017
Messages
64
Reaction score
14
@spectra9

I ran this one yesterday.
Mission Hub - Litchi

Rod
Thanks, looks nice. Does litchi has a "return to first waypoint" command? I tried to imitate this by putting the last waypoint on top of the first, which I think was what causing the "too close" error.

Anyway, I don't think my issue has to do with waypoint, because all the go home actions were not in mission mode, I never succeed to run the mission in the first place
 

New Threads

Forum statistics

Threads
138,530
Messages
1,430,443
Members
100,541
Latest member
six2twelve