Litchi and DJI GO

Joined
Dec 20, 2015
Messages
107
Reaction score
37
Location
Edmonton, Alberta - Canada
I just have a quick question regarding Litchi and DJI go app,
Flying P3P usually with DJIgo but I invested and bought Litchi, now my question is litchi pops up with a notification of force stop DJI go on the tablet, I got a 7" samsung tab 4, I heard that on DJI forum that one guy was flying in autonomous mode on litchi and DJI go initiated shut down in mid air and his drone fell off the sky.
Apparently DJI go was running in the background while he was flying on litchi and for some reason downed his drone, by all means I want to avoid that lol.
So I went into the tablet setting and sure enough even though DJI go is not turned on it sure does run in the background, ok , so at home I set up my drone propless and turned the drone and controller on loaded litchi and all is good, started the drone and let it coast.
I went into the tablet settings and force stopped the DJIgo app, switched back to litchi , played with some settings while the drones idling, after about 5 minutes I go back into tablet setting and the devil is back on running in the background lol, how to I stop this pos from running in the background ??
I do want to have both apps installed just in case but I do not want the **** DJIgo to run in the background unless I initiate that app... anyone ?
is there perhaps an app that can prevent certain apps from running in the background ?
I do want to test fly litchi today but I am a bit cautious as I do not wanna hard land my drone ...
any help would be appreciated.

thanks !
 

alokbhargava

Premium Pilot
Joined
Sep 28, 2015
Messages
6,943
Reaction score
2,322
Location
San Francisco, CA
Something wrong somewhere, DJI Go and Litchi app can be run simultaneously (even in background). Someone probably wrongly claimed it.
 
Joined
Jan 27, 2016
Messages
2,409
Reaction score
892
Location
Ohio
Litchi specifically recommends that Go be shut down before opening their app. Check back through some earlier posts/threads, there has been some discussion on how to shut it down and make it stay off on android devices.
 
Joined
Nov 4, 2016
Messages
244
Reaction score
88
Age
44
I ran into the same problem lol no matter what I did to force stop dji go even used advanced task killer dji go would start back up in the background. While it was running in the background litchi would act weird at times so I eventually just uninstalled dji go and it's been smooth sailing with litchi since. I only have litchi on the tab and on a phone that are both dedicated to litchi and the phantom I don't do anything else with them and I use dji go on my normal everyday phone.

Sent from my SM-S320VL using PhantomPilots mobile app
 
Joined
Jan 5, 2016
Messages
524
Reaction score
157
Age
46
Location
Zagreb, Croatia, Europe
Go to Settings/Device/Apps and check if Open by default option is set for either Go or Litchi. If it is, clear it so it says No defaults set. When you connect your tablet/phone to RC there should be a popup window asking would you like to use Go or Litchi. Choose one and use Only once option.

Sent from my SHIELD Tablet K1 using PhantomPilots mobile app
 
  • Like
Reactions: Paul A Byers
Joined
Dec 20, 2015
Messages
107
Reaction score
37
Location
Edmonton, Alberta - Canada
I ran into the same problem lol no matter what I did to force stop dji go even used advanced task killer dji go would start back up in the background. While it was running in the background litchi would act weird at times so I eventually just uninstalled dji go and it's been smooth sailing with litchi since. I only have litchi on the tab and on a phone that are both dedicated to litchi and the phantom I don't do anything else with them and I use dji go on my normal everyday phone.

Sent from my SM-S320VL using PhantomPilots mobile app
thanks for your replies,
yes that is exactly what I'm experiencing on my end, DJI go always loads up as active in the background..., I am gonna get rid of it as soon as I'm more comfortable with Litchi, I noticed already that the video transmission is so much smoother and the maps load up so fast , DJIgo for me is a complete disappointment, also such a video lag , litchi appears to be about 0.5 seconds video delay, looks like a great app..
I will take it for a first flight tomorrow.

thanks guy !
 
Joined
Dec 20, 2015
Messages
107
Reaction score
37
Location
Edmonton, Alberta - Canada
Go to Settings/Device/Apps and check if Open by default option is set for either Go or Litchi. If it is, clear it so it says No defaults set. When you connect your tablet/phone to RC there should be a popup window asking would you like to use Go or Litchi. Choose one and use Only once option.

Sent from my SHIELD Tablet K1 using PhantomPilots mobile app
I did that, the problem is not the default setting but DJIgo activates in the background task while operating Litchi,
Chinese spying app lol JK !
 
Joined
Dec 20, 2015
Messages
107
Reaction score
37
Location
Edmonton, Alberta - Canada
That is wierd. Do you even get Open with popup window when you connect RC and tablet?


Sent from my iPhone using PhantomPilots
yes it does comes up as a popup asking which app I want to use as default, but once Litchi is selected go into your tablet task and see that DJI go is active, not launched but it's on, you can force it to shut down , but next 5 minutes it comes back on in the background task..
 
Joined
Jan 5, 2016
Messages
524
Reaction score
157
Age
46
Location
Zagreb, Croatia, Europe
yes it does comes up as a popup asking which app I want to use as default, but once Litchi is selected go into your tablet task and see that DJI go is active, not launched but it's on, you can force it to shut down , but next 5 minutes it comes back on in the background task..
Something is triggering it. Try uninstalling Go and then doublecheck permissions it will require on reinstall.


Sent from my iPhone using PhantomPilots
 

New Threads

Forum statistics

Threads
135,803
Messages
1,404,900
Members
98,868
Latest member
Timmo