Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Lightbridge broke my P2?

Discussion in 'DJI Lightbridge' started by admax02, Jun 28, 2014.

  1. admax02

    Mar 30, 2014
    Likes Received:
    Ok so I've had a P2 (in NAZA mode) and H3-2D since it came out. Have gotten along pretty good (other than one battery going bad). No major wrecks.

    P2 already on 3.04 software (although P2 assistant software shows 3.4? wtf? -- reinstalled P2 assistant and then its 3.04 again)

    Yesterday opened it up to upgrade to H3-3D and Lightbridge (never had FPV before).
    Install went smooth and exactly like the DJI video

    Fired it up, updated software for ground end, air end, and h3-3d.
    Again, process went good.

    Hook up ground end to my Nexus 7 tablet and T8FG trainer port.
    Video works great, but no control with the sticks on the T8FG, and it appears stuck in failsafe.
    So messed around with it awhile, did the cal in Lightbridge assistant, etc.
    Video continues to work great, but no other control.
    So, I unplug the T8FG from the trainer port, P2 starts flashing yellow, so I know it sees the controller.

    Dealer suggested putting back to stock and making sure everything works there.
    So, that's what I do, even leave the gimbal completely unhooked too since it's new as well.

    Now, every time the P2 is turned on I get 3 quick red lights, which I guess indicates sensor out of range.
    Where do I go from here?

    Was careful with the compass, no magnentic screwdriver, and P2 even let me calibrate it because my S1 and S2 switches work. Still no control sticks though (keep in mind back to all stock, even stock controller).

    Tried basic IMU cal. Worked fine.
    Did advanced IMU cal, it tells me temperature of MC is too high.
    Turned off, tried again, temp message comes up again right away.

    So now I'm at a loss. I realize it's complicated, but where do I go next?
    Back to DJI for warranty and wait 4 weeks+?
  2. sar104

    Mar 22, 2014
    Likes Received:
    Los Alamos, NM.
    The original problem - stuck in failsafe - is caused by the servo outputs from the Futaba being interpreted differently by the Lightbridge than the P2 receiver. You cannot calibrate that out via the LB calibration - you have to fix it on the Futaba by adjusting the servo endpoints on the Futaba channel 7 while watching the U channel in the Phantom Assistant software. You will probably need to drop the endpoints down to around 70, from 100 which is the default.

    Once the U channel is out of failsafe then you can do the LB and P2 channel calibrations as usual.
  3. admax02

    Mar 30, 2014
    Likes Received:
    Ok thank you. I did get it all figured out. I don't know exactly what the problem was, I just went back and started over from the very beginning. Re updated software on everything, had to go into rc assistant with original controller, etc. And worked my way step by step back into Futaba and then Lightbridge.f
Similar Threads - Lightbridge broke Forum Date
I think lightbridge is broken Pro/Adv Discussion Apr 14, 2017
Phantom 3 broke LightBridge antenna Pro/Adv Discussion Mar 30, 2016
Lightbridge 2 transmit to different receivers? Phantom 4 Pro Discussion Aug 1, 2017
Can I remove lightbridge from my Phantom? Pro/Adv Discussion Jul 6, 2017