Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Just to say hi and a question

Discussion in 'General Discussion' started by Builder, Nov 30, 2014.

  1. Builder

    Joined:
    Nov 30, 2014
    Messages:
    16
    Likes Received:
    0
    Location:
    UK DEVON
    Just a quick hello from me and hopefully a near future phantom pilot :)
    As I am hoping to get the latest dji phantom vision 2 + in the very near future, I was wondering if someone could answer a question for me. As I am new to the pv2 I have been researching it quite a lot and have been following/ looking at videos on you tube which are very helpful.
    The question relates to the "software assistant" which I need to install on my iMac. I have been onto the dji website but it only has the software for os 10.9 or above! As I am running os 10.7 at the moment, I tried to see if it would download and it did but I cannot open it, it will not open at all. Is there a version for 10.7? Or do I need to upgrade my os system which I don't really want to do as I have read some bad things about the latest systems and I'm a bit dubious to do it, so if there is a way around this that would be good news. Great forum by the way lots of info for a newun.
    Many thanks in advance :)
     
Loading...
Similar Threads - question Forum Date
Location Question Rules and Regulations Jan 13, 2018
Question about flight outside of national forest Rules and Regulations Jan 13, 2018
Dumb question. Phantom 1 Discussion Jan 12, 2018
Newbie here...Question : Does the GPS/ap automatically disable the drone within FCC proximity guidel Introductions Jan 12, 2018
questions before first Litchi test Control (Go, Litchi, etc..) Jan 12, 2018