Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Input lag and bad radio connection

Discussion in 'Phantom 1 Help' started by hasofy, Jul 22, 2018.

  1. hasofy

    Joined:
    Sep 4, 2013
    Messages:
    86
    Likes Received:
    24
    Hi,

    I have problem with connection to my old P1 bird, with a thousand flights or so since it was born. I fly it fast and brutal for fun and recently crashed really hard into a tree, found no components broken after eye inspection, only replaced the completely trashed shell, ordered another set of fresh batteries, more propellers and was ready to fly again but the bird behaves strangely. Every flight, from time to time the bird has some lag when following stick inputs, a second or two. It then can keep flying in a direction without stick input, as it had some AI, enabling it fly on its own. Quite dangerous. It also has a tendency to loose connection easily, only a two hundred meters away or so, starting to return to home. Today it was returning home and dropped from the sky suddenly, maybe it was trying to preform a previously entered stick input downwards, no idea. Oh, when I replaced the shell, the old antenna snapped off in the middle, I welded it back together and made a wrap around it, maybe that might be a problem. Would like to keep the bird alive, as it is supposed to serve as learning ground for my son and I just invested in a shell and new batteries.

    What do you think guys, what could it be and what should I do next?

    Thanks in advance!
     
  2. daveloves

    Joined:
    Oct 19, 2015
    Messages:
    80
    Likes Received:
    4
    Location:
    South Jersey
    When you take the shell off next time, you need to take a closer look at all the connections and inspect all components carefully. Also could have damaged the GPS but would definitely replace the antenna. Beat of luck
     
  3. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    6,536
    Likes Received:
    2,383
    Location:
    Australia
    The bad connection is likely to be the antenna cable you butchered during the shell replacement. I would fit a new one rather than trying to repair it. Other flight issues could be a damaged IMU from the imoactvwith the tree. What are the MOD values for the IMU? Can you perform a calibration?
     
  4. hasofy

    Joined:
    Sep 4, 2013
    Messages:
    86
    Likes Received:
    24
    Thanks! I inspected them, hit battery first, became stuck high up in the tree:) I will order a new antenna and replace, see if that solves the issue. I have not calibrated and checked it for ages, as I have a Mac and no admin rights on my work Windows laptop anymore. Will look for a Windows computer among friends when back at home.
     
  5. hasofy

    Joined:
    Sep 4, 2013
    Messages:
    86
    Likes Received:
    24
    Guys, I need help in finding OEM or another suitable antena cable for the bird itself. I have searched online and can not find it. Would be very thankful for support.
     
  6. hasofy

    Joined:
    Sep 4, 2013
    Messages:
    86
    Likes Received:
    24
    ..or do I need to replace the whole receiver module?
     
  7. hasofy

    Joined:
    Sep 4, 2013
    Messages:
    86
    Likes Received:
    24
    I replaced the receiver module, as antenna was not sold separately. I’ve flown a dozen packs and my old bird performs flawlessly again at any distance. Thanks for support!
     
  8. hasofy

    Joined:
    Sep 4, 2013
    Messages:
    86
    Likes Received:
    24
    It was the antenna, thanks!
     
Loading...
Similar Threads - Input lag bad Forum Date
Send in for repair ? Need your input . Phantom 4 Pro Discussion Aug 11, 2018
Amplifier 5.8ghz input Standard Jul 21, 2018
P3S antenna inputs Standard Feb 19, 2018
dji goggles NO HDMI INPUT VIDEO just sound- needed for movies xbox etc DJI Goggles Jan 24, 2018
Photogrammetry project, looking for input from others. Surveying and Mapping Jan 19, 2018