Hey! got my phantom standard today

Joined
Apr 3, 2016
Messages
21
Reaction score
3
Age
60
Location
Stockholm
Hey! got my phantom standard today, but there is one
thing that I think is strange
When I try it without the propeller,
I noticed that there is no sensitivity on the throttle?
when the throttle is in the middle the propeller
spins slowly and when I raise the gas so laps it up at
full throttle ??? What is wrong?

Sampler
 
Try calibrating your remote controller -- like this:

 
Try calibrating your remote controller -- like this:

Still the same error
Please can someone remove the propeller and test if it is possible to adjust the throttle stepless 0 -100 %
 
Still the same error
Please can someone remove the propeller and test if it is possible to adjust the throttle stepless 0 -100 %
 
I am not 100%sure. But it could just how the phantom behave under p-gps DJI take off mode. Just a guess

Found a open area. Use auto take off. Fly a bit. Use auto land Maybe all this worry and headache is all for nothing

Sent from my iPad using PhantomPilots mobile app
 
I'm wondering if the motors are just winding up to full speed due to zero load.

Sent from my SM-N910V using Tapatalk
 
I am not 100%sure. But it could just how the phantom behave under p-gps DJI take off mode. Just a guess

Found a open area. Use auto take off. Fly a bit. Use auto land Maybe all this worry and headache is all for nothing

Sent from my iPad using PhantomPilots mobile app
Thanks! Should test tomorrow
 
Okay, it was so that soon as it was in the air so worked throttle
as usual Thanks!:D
 

Members online

Forum statistics

Threads
143,153
Messages
1,468,002
Members
105,051
Latest member
stovesparesdirectuk