Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

green...green...green...green..fast red blink

Discussion in 'Phantom 2 Vision Discussion' started by helixaviator, Oct 15, 2014.

  1. helixaviator

    Joined:
    Jan 1, 2014
    Messages:
    138
    Likes Received:
    0
    What does it mean if my P2v is flashing four slow green blinks followed by a fast red blink? Also the GPS icon on the app is grayed out...0 satellites and battery icon grayed out as well. Anyone have this problem? Its always something with this thing..let me tell you!
     
  2. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    430
    Location:
    North York Moors
    If it stays on 0 satellites there may be a problem with the satellite antenna (in top shell)

    You might try taking off in ATTI mode to see if it will get more when clear of the ground.
    It can be borderline if surrounded by trees or buildings at ground level and certain times of day there are sometimes only 5 or 6 sats available.

    You might find that when you tried it was a particularly bad moment for satellites at your location - see this predictor tool
    http://satpredictor.navcomtech.com/
     
  3. SayntJ

    Joined:
    Oct 12, 2014
    Messages:
    19
    Likes Received:
    0
    Is that part of the new firmware?
    Before I updated to 3.06 the LEDs would flash yellow before it had a GPS fix. Now it's doing the green green red dance. I thought it was because I switched to Naza-M in the assistant software to use Ground Station.
     
  4. SayntJ

    Joined:
    Oct 12, 2014
    Messages:
    19
    Likes Received:
    0
  5. scubari

    Joined:
    Mar 29, 2014
    Messages:
    59
    Likes Received:
    0
    i had the same lights today..first time for me.
    I did have good sat´s, but fast red blinking.. in manual it is error ( http://wiki.dji.com/en/index.php/Naza-M ... escription ) , so i did not take off. Came home, connect to assistant,,all looks to be ok. I did basic imu cal and went for another try,
    no red light´s, so all good, went for a flight and all systems were working good, only had early autolanding once again, but i dont think that´s related to fast red blinking..
     
  6. speedfight1992

    Joined:
    Jul 11, 2017
    Messages:
    6
    Likes Received:
    0
    I'm getting same problem have u fixed it ? Started after update it's like it's stuck in naza mode I did put it back to phantom mode bit still get the same lights
     
  7. N017RW

    Joined:
    May 2, 2014
    Messages:
    7,950
    Likes Received:
    2,488
    Location:
    Palm Beach Co.- FL
    Fast red (all 4 arms) is [critical] low voltage, auto-land will follow.

    The P2s have a 'hidden' LVC at 10.65vdc.

    Why do you suspect otherwise?
     
  8. speedfight1992

    Joined:
    Jul 11, 2017
    Messages:
    6
    Likes Received:
    0
    Because it's only hopping after update it was working perfectly before the update now I get the lights
     
Loading...
Similar Threads - green green green Forum Date
Green screen...laggy video when flying Phantom 4 Help Dec 27, 2017
Landscape around Green River Wyoming Photos and Video Dec 18, 2017
4K 60 Video Problem (Green Stripes) General Discussion Dec 16, 2017
How I fixed the P4 firmware red/green flashing and video feed issue Phantom 4 Discussion Dec 14, 2017
P4 Firmware How I fixed the P4 firmware red/green flashing and video feed issue Firmware Dec 14, 2017