Gimbal wobble after crash

Joined
Feb 11, 2016
Messages
56
Reaction score
7
Location
Durham United kingdom
Hi everyone I'm really hoping someone can help me

I had a low altitude crash from about 10ft and now there is a noticeable wobble on video.




If you turn volume loud you can hear the vibration and see it on the top plate (one with the light on)


It also does it with no props on eliminating that.

There is no noticeable damage although a slight mark on the silver coin shaped thing to the left of the camera where it landed and all mounts are ok although It has bent something as Ive had to remove the aluminium gimbal guard (see below) as it was rubbing the back of the camera when pitching and also the gimbal clamp was tight to get in before removing aluminium guard.

IMG_0679.JPG

When I use the p1 button to change the camera from down to up it also shakes video ,I've tried recalibrating with no luck .

It does look as though the camera is no longer perfectly symmetrical to the front but I can't remember if it was.

Anyone had this problem before or know if its bent arm or motor ?

Ive tried tightening the yaw arm screw but it wasn't loose.
 
Last edited:
Joined
Feb 11, 2016
Messages
56
Reaction score
7
Location
Durham United kingdom
Is it the roll motor? can u put up a video?
either that or pitch but its really hard to distinguish .The Pitch motor took the impact .

Heres the vid but its really hard to see ,if you turn volume loud you can hear the vibration and see it on the top plate (one with the light on)

 

New Threads

Forum statistics

Threads
137,497
Messages
1,421,108
Members
99,858
Latest member
aeromaxgse