Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. r62ewa

    Joined:
    Mar 30, 2016
    Messages:
    714
    Likes Received:
    179
    First time transporting my Phantom in a speedboat this weekend, I had it secured in the Nanuk 945 and the water wasn't too rough so it never got knocked around.

    When I started the Phantom the camera was just rolling up then down repeatedly but it stabilized after a few seconds. Then when I was hovering over water shooting video of my kids throwing rocks in the water it seemed to lose RPM briefly and lost a little altitude, I was maybe 30 feet over the water. And finally, at one point during a hover it pitched to the left quickly like it was going to fly in that direction, without any input from me, and then stabilized again.

    Just minor glitches I hope.
     
  2. Technodynamic

    Joined:
    Jun 5, 2016
    Messages:
    65
    Likes Received:
    19
    Bermuda Triangle
     
  3. Helihover

    Joined:
    Jun 23, 2016
    Messages:
    619
    Likes Received:
    365
    Location:
    Oregon
    Did you have your OA on?

    OA has been known to make the Quad "glitch" over water. It's a general recommendation to turn it off while flying over water.
     
    Santiego likes this.
  4. r62ewa

    Joined:
    Mar 30, 2016
    Messages:
    714
    Likes Received:
    179
    From my understanding OA should have no effect, however, VPS would and we cannot disable it on our Phantom 4's.
     
Loading...
Similar Threads - Few Glitches Forum Date
A new drone video of mine... can I get a few tips? Photos and Video Aug 15, 2017
Recording management: few long or many short? Photos and Video Aug 12, 2017
A few from tonight's storm... Photos and Video Aug 9, 2017
Facebook Live only lasts a few seconds Phantom 4 Pro Help Jul 1, 2017
Radar indicator, and a few other questions Pro/Adv Discussion Jun 30, 2017