Fatshark battery & phantom charger.

Joined
Nov 7, 2013
Messages
2
Reaction score
0
I recently bought Fatshark dominator set, but I have problem trying to charge the battery that comes with it.

When I plug it in to the phantom charger, only the 2S light blinks, slowly once in 3 - 4 seconds. Kept it like that for few hours, nothing seemed to change. The other lights stay dim.

I tried plugging it into the goggles, everything seems to work, and there seems to be enough charge in the battery, not sure how much.

I tried measuring the voltage with multimeter while plugged into goggles. One cell gives 3.81V other one 3.84V.

Any ideas what could be the problem?
 
Joined
Sep 20, 2013
Messages
43
Reaction score
0
Are you plugging in both cables? With mine I have to use a supplied adapter for the main power then also plug in the balance connector.
 
Joined
Nov 7, 2013
Messages
2
Reaction score
0
Yes, both cables are connected. Balancer to 2S port, and the barrel connector through supplied banana plugs to the charger.

Polarities are also correct, I doublechecked them with multimeter.
 
Joined
Jan 25, 2013
Messages
1,859
Reaction score
4
Location
Sherman Oaks, CA
the Phantom charger is about as cheap as they come, and seem to have troubles charging certain batteries if they are unusually low on mah to begin with.

There's not much of a fix if you plugged everything in properly, set it to Lipo and 1A and the battery doesn't appear to charge.

But your best bet is to look into getting a more robust "real" Lipo charger that's much more capable of charging, storage charging, etc., with a digital readout.
you'll be much better in the long run
 
Joined
Dec 5, 2013
Messages
4
Reaction score
1
Mine (Phantom Charger) was doing the same thing and the Lipo switch had been bumped. I moved it to the left (Lipo) and it (the Fatshark Battery) started charging normally.
 
Joined
Jan 8, 2014
Messages
15
Reaction score
0
Age
34
Location
San Francisco, Ca
I don't really feel like buying a proper charger for my fatshark battery, do you guys think this setup will work ? I cut the end off of this charger I found in the trash, it says " 5v - 1Amp" the fatshark battery is "7.4v - .76Amp" close enough right?
 

Attachments

New Threads

Forum statistics

Threads
136,173
Messages
1,408,430
Members
99,080
Latest member
luiss