ESC's not lighting up during boot sequence

Joined
Jul 12, 2015
Messages
21
Reaction score
2
Age
36
Hi guys,
I'm having an issue with the LEDs on 3 of the ESCs not lighting up during the boot sequence. They all light up during flight mode and the bird flies just fine but its a bit annoying.

A bit of history on the bird, I had to replace 2 ESCs (v2.0) a while back and it hasn't worked since then, I've also noticed that the sound of the boot sequence is significantly muted (if playing at all) on the ESCs that don't light up.

Has anyone else had this issue or know how to fix this?

Thanks
J
 

N017RW

Premium Pilot
Joined
May 2, 2014
Messages
8,961
Reaction score
3,241
Location
Palm Beach Co.- FL
Hi guys,
I'm having an issue with the LEDs on 3 of the ESCs not lighting up during the boot sequence. They all light up during flight mode and the bird flies just fine but its a bit annoying.

A bit of history on the bird, I had to replace 2 ESCs (v2.0) a while back and it hasn't worked since then, I've also noticed that the sound of the boot sequence is significantly muted (if playing at all) on the ESCs that don't light up.

Has anyone else had this issue or know how to fix this?

Thanks
J

JM,
You can find un-official, reverse-engineered, schematics for the P2 Main & ESC PCboards here:
WIP Phantom 2 PCBs, Schematics and Info

Scroll to the bottom of the post to get the 'zip' files as they're easier to read.

The lighting is controlled by PWM signals from the embedded processor, U1, on the main PCB which is decoded by U1 on the ESC PCB to determine color and 'blink' sequence.

I have not ever had to troubleshoot but you may try swapping ESCs to see if you can determine fault.

Also the start-up beeps are generated by the motors being pulsed much like a speaker. This may help you troubleshoot.
 
  • Like
Reactions: Mark The Droner
Joined
Jul 12, 2015
Messages
21
Reaction score
2
Age
36
JM,
You can find un-official, reverse-engineered, schematics for the P2 Main & ESC PCboards here:
WIP Phantom 2 PCBs, Schematics and Info

Scroll to the bottom of the post to get the 'zip' files as they're easier to read.

The lighting is controlled by PWM signals from the embedded processor, U1, on the main PCB which is decoded by U1 on the ESC PCB to determine color and 'blink' sequence.

I have not ever had to troubleshoot but you may try swapping ESCs to see if you can determine fault.

Also the start-up beeps are generated by the motors being pulsed much like a speaker. This may help you troubleshoot.
Thanks for the link mate, most of that information is a bit outside of my wheelhouse but I was able to establish that the v2.0 ESCs don't have the additional 4 beeps on the boot cycle. So it would seem that I have 3 v2s and 1 v1 escs on the bird which explains the muted sounds.

The rest of the cycle sounds are nominal (1,2,3,4,5,6,7,8).

Could this mismatch of ESCs also be the cause for the LEDs problem?

Can anyone anticipate any problems before I send the bird on its maiden voyage with regards to mismatched ESCs?


Sent from my iPhone using Tapatalk
 

Mark The Droner

Premium Pilot
Joined
Aug 26, 2015
Messages
5,311
Reaction score
1,740
I've replaced several original ESCs with the newer V2 ESCs and have never had a problem.
 

New Threads

Forum statistics

Threads
136,677
Messages
1,413,393
Members
99,355
Latest member
axident