Erratic Gimbal

Joined
Feb 16, 2020
Messages
17
Reaction score
7
Age
46
So I crashed my P3S and broke (cracked) one of the gimbal arms. I took it apart and tried to glue (not very well) and put it back together. Now I get the famous camera dance. I've taken it apart 2 more times and checked all connections but can't figure out what I did wrong. Figuring I have a bad cable I ordered a repair kit that includes the cable and the broken arm. So when I do this again what is the orientation I am looking for with arms in relation to the camera. Here is how the camera looks now. 3rd pic shows the crack.
 

Attachments

Joined
May 1, 2017
Messages
2,987
Reaction score
2,160
Age
66
Location
N.central wv. U.S.
I'm in bed now, but it looks like it is 45deg. out. That opened port is where the grey coaxial wire goes. It should be facing the side of the drone. Please check it carefully as I can make mistakes. At least by what my wife says.
 
Joined
Apr 25, 2020
Messages
41
Reaction score
22
youtube irepairmd channel. He's got some great videos on phantom repairs.
 
Joined
Feb 16, 2020
Messages
17
Reaction score
7
Age
46
Ron-ep, I saw that video before I posted this. I’ve gone over the camera several times and it seems to be put back together correctly. I did notice the ribbon cable is frayed very slightly. I am replacing it along with the arm. Hope it works when I get the parts.
 
Joined
Feb 16, 2020
Messages
17
Reaction score
7
Age
46
I received my new gimbal parts with ribbon cable. Everything looked ok until I went to install. It seems the replacement gimbal arm for the part I broke wasn't make very well. There are 5 screws that secure a cover. 3 out of the 5 screw holes either don't have thread or are too big. Screw doesn't stay secure. Moving on. I followed many youtube videos and installed the new ribbon cable. The new cable does not line up as well as the oem. So again not good. Moving on I get the cam back together and connected. Go for a test and once again have the crazy gimbal action. Also now I am getting a motor overheating error. I have searched and searched and searched and also taken the gimbal apart 10 times but cannot find an issue. Not sure if I have a bad cable, broke something on one of the board, or have something misaligned. I am at the point where I need to take the gimbal apart piece by piece and put it back together ensuring I have the correct orientation. Only problem is I cannot find a definitive guide that shows this. Anybody need a parts drone?
 
  • Like
Reactions: krodshat2020
Joined
Feb 16, 2020
Messages
17
Reaction score
7
Age
46
Can anyone suggest a repair center to send the gimbal in for repair?
 

KachemakDiver

Premium Pilot
Joined
May 15, 2019
Messages
599
Reaction score
457
Age
57
Location
Homer,Alaska
Check the orientation of the flat side of the roll motor shaft. It should be positioned at exactly 12 o’clock.( the flat side facing up ).
 
Joined
Feb 16, 2020
Messages
17
Reaction score
7
Age
46
Thank you all for the help and suggestions. With this site and searching many youtube videos. I was able to get the gimbal issue resolved. I literally took the camera and gimbal apart 10 times and ended up using 2 ribbon cables. Either I got a bad cable or messed it up the first time around. Just took the drone for a flight today and except for interference/connectivity issues it flew great. I think my area has a lot interference.

This is the video that showed the orientation I needed.

 
Joined
May 1, 2017
Messages
2,987
Reaction score
2,160
Age
66
Location
N.central wv. U.S.
I'm glad it all worked out for you. You have learned a little. Lol Now you are a P3s gimbal specialist from the school of hard Knox. I'll be sending everyone to you. Lol
 
Joined
Apr 15, 2020
Messages
5
Reaction score
1
Age
35
Hi guys !
I've got that shaky gimbal dance problem too after a crash. My problem is that everything looks OK. The Ribon cable looks great, the roll motor shaft is well positionned.
The crash did some bad damages on the P3S mainboard. The compas connector went away, and a friend of mine soldered it back. Could the gimbal issue come from the P3 mainboard or is it independant ?
 

New Threads

Members online

Forum statistics

Threads
138,479
Messages
1,429,953
Members
100,501
Latest member
yunior979