Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI Phantom 1.1.2 Receiver Board Binding Not Sticking

Discussion in 'Phantom 2 Vision + Help' started by tranzfusion, May 22, 2014.

  1. tranzfusion

    May 22, 2014
    Likes Received:
    Firstly, hi!, i'm a NOOB - and have just built my first quad.
    I lost my Phantom a while back - so have built my own quad and am using the Phantom transmitter until i can upgrade to a dx8.

    Just finished the quad builld (Reptile 500 frame with Naza V2+Gps, simonK escs, outrunner 1000kv motors)
    I purchased a replacement stock receiver board (1.1.2 - the dual antenna version - which is what i had in my sunken phantom) and have put it all together.

    The receiver board has 2 sets of servo pins - unlabeled - and by trial and error I've worked out which way and which sets of pins to use

    I've wired it all up - and all seams to the working - but i'm having an issue with the transmitter, having to rebind after each power on.
    Not sure if i'm supposed to have the other sets of pins wired somewhere? Or if there's something obvious i'm not doing correctly.

    When i power up the quad, the receiver is flashing green (transmitter on) - I hold the bind button for 2 seconds, it flashes red then binds with solid green - and then all is fine. (i can fire up motors etc)
    If i power off the quad, and plug it back in - i need to rebind it again.

    I've tried updating the firmware on the transmitter, and calibrating but same story.

    Hoping someone can shed some light - otherwise i'll invest in a new receiver - its just that i'm based in Cambodia - so will take weeks to arrive

    On another note - any recommendations for a receiver that will work with the stock transmitter (1.1.2 with the tilt knob on the back)

    Thanks in advance!
  2. discv

    May 7, 2013
    Likes Received:
    London, UK
    Just been all through this myself. Are you using a Naza v2 which is not from a Phantom?

    If so- the Phantom Rx will not bind correctly. I think it has something to do with the firmware. You will notice on DJI support that the firmware for the Phantom, is marked as for the Phantom only.

    You could be adventurous and load the phantom version of firmware, but I don't think that's a good idea.

    Best bet is a new [non Phantom] Rx. If you are using a stock Tx any Futaba compatable Rx will do.

    Edit; thought I should qualify the above post. The incompatibility was discovered by Helipal support. I question this and contacted DJI. They replied :eek: - and confirmed that a Phantom Rx board will only work in a phantom-or at least with a phantom Naza.

    I got hold of a DT7 combo- and all is good
  3. daveloves

    Oct 19, 2015
    Likes Received:
    South Jersey
    Which set did you use? I am having the same issue. Front pair or back pair?
  4. dgd3

    Aug 10, 2015
    Likes Received:
    While a NOOB myself I spent lots of frustration binding to the wifi extender. Got told by a fellow pilot to bind to camera. Frustration gone, stupid feeling remained till my first successful flight. :)
Similar Threads - DJI Phantom Receiver Forum Date
DJI remote controller of Phantom2 - which futaba receiver? Phantom 2 Help Mar 18, 2016
difference between DJI Phantom 2 receivers General Discussion Nov 3, 2014
DJI Phantom Radio Receiver Other DJI Multi-Rotors Aug 18, 2014
What Transmitter/Receiver to buy for DJI Phantom 2 ? Photos and Video Feb 10, 2014
DJI Phantom 4 GOLD Edition... Off Topic Friday at 4:59 PM