Professional Dji Go App 2.6.1 downgrade

Joined
Aug 14, 2014
Messages
157
Reaction score
19
Has any one got a link or have the file go.apk 2.6.0?
As i have a friend that has upgraded to 2.6.1 but he has batteries that are now made by DJI and he says the app does not allow take off as it says they are not dji batteries.
I find this strange as the app does not have anything to do with take off ect and he has not upgraded any firmware.. maybe the app just refuses to work.
I will speak to him later to find out what is what but just warning anyone who has any batteries not made by DJI until someone finds out if their is a problem.
Dont affect me as i use ios and would never use cheap copied unofficial l non dji items that have anything to do with flight or control
woops think i just posted in wrong area, can it be moved admin?
 
Joined
Aug 14, 2014
Messages
157
Reaction score
19
not me, he got them from ebay and some lcd ones too and they apear to not be working still, so warning to all that have non DJI batteries, the app says:
"none dji battery detected .aircraft flight prevented.
SO PLEASE DOES ANYONE HAVE THE 2.6.0 APP IN ANDRIOD FORMAT?
 
Joined
Feb 13, 2016
Messages
37
Reaction score
6
Location
Derby, UK
I really don't think it's worth cutting corners with batteries. If you've just spent a ridiculous amount on buying a P3 then why not be super safe and get an official battery :)

I really wouldn't recommend flying non-DJI official batteries. Some people probably fly them with no problems but is it really isn't worth the risk of all that money just plummeting out the sky when the battery cuts off. In my opinion I'd get a refund and buy official batteries.
 
Joined
Sep 26, 2015
Messages
757
Reaction score
152
Probably dji putting crap in the update to disable clone batteries. Seems kinda par for the course.
 
Joined
Jan 1, 2016
Messages
841
Reaction score
216
Age
65
Location
Ontario, Canada
I can understand DJI doing this if the craft was under warranty. But after that it is non of their business.
They must make a big profit on the battery's.
 
Joined
Sep 26, 2015
Messages
757
Reaction score
152
Exactly. We live in a different world today. If it profits you or your company, its ok.
 
Joined
Aug 14, 2014
Messages
157
Reaction score
19
I now have the apk file and will downgrade it for him this morning, thank you all and special thank you to you know who you are ;)
 
Joined
Mar 18, 2016
Messages
5
Reaction score
2
Age
64
I've had the same problem with a Powerextra battery I purchased on Amazon. Worked fine for weeks but started getting the non-DJI error after a recent app update, as others have described. HOWEVER, I found that the warning does not occur if you use a third party app. I use Autopilot from Autoflightlogic.com, which is a far more powerful app than the DJI app. When I fly with that app, the warning does not pop up and flights proceed as before. I guess this confirms the "problem" is in the app on the Smartphone/Tablet.
 
Joined
Feb 20, 2016
Messages
6
Reaction score
3
Age
38
Does this issue not occur on iOS? Seems like all the threads I see on this topic are Android users.
 
Joined
Mar 18, 2016
Messages
5
Reaction score
2
Age
64
Does this issue not occur on iOS? Seems like all the threads I see on this topic are Android users.
Yes. I occurs on both my iPhone and my iPad. But it only started happening after updating to the most recent app version earlier this week.
 
Joined
Feb 20, 2016
Messages
6
Reaction score
3
Age
38
That's what I was afraid of. Now I need to figure out how to revert to 2.6.0 on my iPad. :(
 
Joined
Feb 15, 2016
Messages
2
Reaction score
0
Age
59
I have a p3s. I upgraded firmware it 1.4.5. I have one Dji batt and one knock off batt. Both batteries worked just fine prior to the upgrade. After upgrade, 3rd party batt won't let me take off. I called Dji support. I got a line of company propaganda. They said that the 3rd party batt was unsafe and my drone could just fall right out of the sky. I told them that it worked just fine before update. I asked if I could go back to the old firmware where my battery worked- that firmware is unavailable. Thanks a lot DJI


Sent from my iPad using PhantomPilots mobile app
 

New Threads

Forum statistics

Threads
134,995
Messages
1,396,687
Members
98,376
Latest member
BamBam79