Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Couldn't shut down battery

Discussion in 'Standard' started by drexdis, Jan 16, 2016.

  1. drexdis

    Joined:
    Jan 16, 2016
    Messages:
    3
    Likes Received:
    0
    Hello,

    This is my first post.
    Just received my first p3s. I tried installing the latest firmware on android and then something strange happened. Heard some usual sounds, after that all the led went red, made the same sounds like three times and then self restarted the aircraft. After that no sound, no led battery light, couldn't shut down the aircraft. Had to remove the battery while on...

    What happened? What should i do/done?

    Thanks
     
Loading...
Similar Threads - Couldn't shut down Forum Date
Couldn't help it... got a Spark. Other DJI Drones Nov 24, 2017
I couldn't exit intelligent flight mode! Phantom 4 Pro Discussion Oct 22, 2017
Couldn't use Litchi last 3 flights, Go worked perfectly...? Control (Go, Litchi, etc..) Aug 15, 2017
Couldn't move stick on remote Phantom 4 Pro Discussion Apr 12, 2017
I made this Top Speed and couldn't believe it. Phantom 4 Discussion Feb 18, 2017