Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't get Futaba T8J and Phantom 2 (non vision) to work

Discussion in 'General Discussion' started by Original poster, Sep 2, 2014.

  1. Original poster

    Joined:
    Jul 19, 2014
    Messages:
    101
    Likes Received:
    0
    Hi all,

    So my Futaba T8J arrived today, got the receiver installed as per YouTube videos and followed That HPI Guys YouTube videos to get it all set up however something isn't right..

    I can not get the props spinning when putting both joysticks to bottom left position (the Phantom is flashing yellow as I'm indoors so no GPS lock, that doesn't matter does it?).

    Also strangely when I move the left stick left or right it adjusts the gimbal slightly.

    I've gone into the Phantom software and calibrated the joysticks (although they are very slightly out after calibration and no idea how to solve this?) but at least I know the radio is talking to the phantom.

    Any ideas guys?
     
  2. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    7
    Location:
    N 44.895 W 93.354 Minnesota
    Double check your "reverse settings" . They should be:
    AIL- NORM
    ELE - REV
    THR - REV
    RUD - NORM
    GER - REV
    FLP - REV
    AV1 - REV
    AV2 - NORM
     
  3. Original poster

    Joined:
    Jul 19, 2014
    Messages:
    101
    Likes Received:
    0
    According to That HPI Guys YouTube video that's correct except GER - NORM however just tried yours and no change unfortunately!
     
  4. Alec

    Joined:
    Jul 20, 2014
    Messages:
    44
    Likes Received:
    0
    Could it be that you need to pull both sticks down and outward (or maybe pull both sticks inwards)?
     
  5. Original poster

    Joined:
    Jul 19, 2014
    Messages:
    101
    Likes Received:
    0
    I've tried just about every combination with the sticks possible and nothing!
     
  6. dcoski

    Joined:
    Jul 21, 2013
    Messages:
    149
    Likes Received:
    10
    Happened to me just the other day with my Phantom 1. Go to the NAZA Assistant, make sure the receiver type is "D-Bus" and calibrate. My throttle wasn't going low enough. It worked.
     
  7. N017RW

    Joined:
    May 2, 2014
    Messages:
    7,389
    Likes Received:
    2,144
    Location:
    Palm Beach Co.- FL
    Also, If the T8 is like the T10, it has it's own separate stick calibration as well.

    I think it was on or near the very last page of the manual.
     
  8. Original poster

    Joined:
    Jul 19, 2014
    Messages:
    101
    Likes Received:
    0
    That's interesting, in one of the videos I saw it had to be in D-Bus however I don't have that option in my Phantom Software?

    [​IMG]
     
  9. Original poster

    Joined:
    Jul 19, 2014
    Messages:
    101
    Likes Received:
    0
    That's good to know, will check it out, thanks!
     
  10. dcoski

    Joined:
    Jul 21, 2013
    Messages:
    149
    Likes Received:
    10
    Hum?? Just for kicks on the "View " page of your assistant what does RC- Receiver Type: say? Mine says "D-Bus".
     
  11. N017RW

    Joined:
    May 2, 2014
    Messages:
    7,389
    Likes Received:
    2,144
    Location:
    Palm Beach Co.- FL
    Yes it is on the view page as I recall as well.
     
  12. Original poster

    Joined:
    Jul 19, 2014
    Messages:
    101
    Likes Received:
    0
    Unfortunately the battery has died on the radio and my charges doesn't arrive till tomorrow so will check it out the. Guys, thanks!
     
Loading...
Similar Threads - Can't Futaba T8J Forum Date
Professional Has anyone connected a Futaba 14SGH with a Phantom 3? I need help and can't find any tutorials! Phantom 3 Help Sep 1, 2015
FUTABA 8J I can't start the engines Phantom 2 Discussion Oct 3, 2014
Can't get my new Futaba Radio to be recognized Phantom 1 Help Aug 30, 2013
Can't get controller and bird to connect. Just updated. Any ideas? Pro/Adv Discussion Yesterday at 8:02 PM
Can't calibrate the compass Phantom 2 Vision + Discussion Yesterday at 3:28 PM