Advanced Camera Acting Up

Joined
Jul 29, 2013
Messages
448
Reaction score
169
Location
Spring Green, Wisconsin
Hi,

I have a 3-year-old Phantom 3 Advanced. I have had nothing but good experience with it until this year. A few weeks ago, we had a nice enough early spring day to get the 'copter out and fly it (probably first time since October or November). All seemed alright, but I noticed that the up/down control on the camera was odd. I'd push the button to snap it straight forward and a few seconds latter it "drooped" down maybe 30 degrees. Did that a few times.

Then, put it away until this past Saturday (5-11-19). Flew it for one battery's worth, just to check it out again. Worked perfectly. Took video, stills, ran it through the fast and slow camera movement... all was groovy.

One day later - 5-12-19 - the camera was gone. No image on the iPad and no control.

Upon startup, the camera did its little dance and all seemed ok. I was able to fly it and since we were just playing around, I only went maybe 50' high and no more than 100 yards away, but no camera whatsoever. It showed altitude, battery level, speed, etc. Just no camera image.

I plan on trying again later today, but if anyone has any insight, I'm all ears. I'm using an older iPad mini with no service, so all of the software, app, etc., is from 2016. I never had any problems so I saw no need to upgrade - the 'copter or the app.

Thanks!!
 
Joined
Jul 29, 2016
Messages
211
Reaction score
86
Age
76
Sound like an intermittent connection between flight system and camera. Check all cables between camera and rest of system.
 
Joined
Jul 29, 2016
Messages
211
Reaction score
86
Age
76
Check both ends of where they plug in. Cables are generally the problem, as they work their way out of the connectors easily.
 

New Threads

Forum statistics

Threads
134,100
Messages
1,387,922
Members
97,788
Latest member
kemco10