Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery doesn't respond to button press - solution.

Discussion in 'Phantom 2 Vision + Discussion' started by CityZen, Oct 22, 2014.

  1. CityZen

    Oct 22, 2014
    Likes Received:
    Recently, I had an issue where the Phantom 2 battery wasn't responding to button presses. At the time, it was on, and I was unable to turn it off. I pulled the battery out and it (the battery) stayed on, completely ignoring my attempts at pushing the button on it. It eventually turned itself off, and at that point seemed very dead, as I could not get it to do anything at all.

    Not wanting to just toss it and spend $130 on a new battery, I opened it up and discovered that the button itself wasn't working - if I shorted the button contacts, it would come on as if I pressed the button (when it worked).

    Going a step further, I pulled the metal top plate off the button itself with a pair of tweezers, removed the plastic plunger, and found two dished-out metal discs inside (convex side up). They had shifted over toward one end of the button interior rather than being in the center where they were supposed to be. In this shifted position, they were unable to reach the opposite contact. I used the tweezers to reposition them in the middle, then put the plunger back in, and was able to snap on the metal securing plate again. (Keep in mind that this whole button package is only a couple millimeters wide - you almost need a magnifier to see it.)

    The battery worked fine again after reassembly. So much trouble from a 5 cent part going wacky.

    Btw, the battery top cap is just held on by the clips that you can see. It's pretty tight, and you have to pry a couple of clips at the same time before the cap moves a bit, but once you get it started, you just keep loosening clips around the top as you go, keeping pressure on it all the time to avoid it snapping back into place. I imagine having an extra set of hands would make this much easier. The frame under that is glued together, but you can break it along the joints and glue it back together again later.
Similar Threads - Battery doesn't respond Forum Date
10% Battery Doesn't Start Charging Pro/Adv Discussion Monday at 8:16 AM
DJI Battery Hub Doesn't Discharge Phantom 4 Discussion Mar 13, 2017
Battery doesn't charge Phantom 4 Help Nov 17, 2016
DJI USB Charger & DJI Battery (10 PIN-A) to DC Power Cable doesn't work Phantom 4 Help Oct 13, 2016
New Battery from DJI doesn't set properly Phantom 4 Discussion May 3, 2016