Atti's mode is always. Compass error appears after 20 seconds.

Joined
Aug 14, 2019
Messages
6
Reaction score
3
Age
28
Hi guys. There is no strength to endure this problem. I'm tired. After a long trip in the car, this problem appeared. How to fix it fast? Give in for repair? Or can I change something myself?
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,364
Reaction score
1,922
Location
Watkinsville, Georgia
How to fix it fast?
There may not be a fast and easy fix for this. We would need to see the flight log that exhibits the issue first and then go from there. It could be that your compass has become magnetized. In that instance you would need to degauss it. If you have a .txt log that exhibits the issue you can directly upload that here or use the link below and upload it there. These files will not work if the error shows up before starting the motors. Log Viewer In that instance we would need the aircraft .dat log. Upload instructions are on the link. If you use that, place a link back here to the uploaded file.
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
@Milaaa,
Welcome to the Forum!

Fix it fast?
Maybe, maybe not. ;)

Long trip in the car does sound like the compass has been magnetized.
This has came up before...., but not a lot.

We are going to need some more information from you. ;)

How long ago did it work and how long was it in the car?

Maybe, where it was stored in the car?

As @Fly Dawg requested, the data can tell us the most.


Rod
 
Joined
Aug 14, 2019
Messages
6
Reaction score
3
Age
28
There may not be a fast and easy fix for this. We would need to see the flight log that exhibits the issue first and then go from there. It could be that your compass has become magnetized. In that instance you would need to degauss it. If you have a .txt log that exhibits the issue you can directly upload that here or use the link below and upload it there. These files will not work if the error shows up before starting the motors. Log Viewer In that instance we would need the aircraft .dat log. Upload instructions are on the link. If you use that, place a link back here to the uploaded file.
The error appears immediately upon startup. (before take-off). How and where to demagnetize? Maybe it will help
 
Joined
Aug 14, 2019
Messages
6
Reaction score
3
Age
28
@Milaaa,
Welcome to the Forum!

Fix it fast?
Maybe, maybe not. ;)

Long trip in the car does sound like the compass has been magnetized.
This has came up before...., but not a lot.

We are going to need some more information from you. ;)

How long ago did it work and how long was it in the car?

Maybe, where it was stored in the car?

As @Fly Dawg requested, the data can tell us the most.


Rod
About a week we traveled by car. The drone was stored in the trunk. Sometimes the drone was stored in the cabin. The drone spent 1 night in a tent in the forest.
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,364
Reaction score
1,922
Location
Watkinsville, Georgia
The drone was stored in the trunk.
Can we assume that a proper compass calibration did not fix the issue? If the aircraft was any where near the car speakers, that would be the reason, since they contain large magnets. It could also be related to your takeoff point. You should not take off any where close to any metallic objects. If the issue persists after a calibration away from anything metallic, and a takeoff spot also away from anything metallic, then that would confirm the magnetism effect. In that instance I would suggest a degauss with a device called C-Fixer. See this link: Degausser
 
  • Like
Reactions: Milaaa

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
@Milaaa,

If you have done what @Fly Dawg has suggested and still got issues, It sounds a lot like most of the posts.

Here are some threads about C-Fixer

If you locate the section in the app, in the IMU calibration area, not sure on a P4's you can view your compass data, I assume if you got numbers then the compass is functioning.

If there are all zeroes then the compass is not repairable or disconnected?
If I'm incorrect on the last sentence somebody chime in....

Rod
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
Hum, two compass's on a P4.. ;)

Rod
 
  • Like
Reactions: Milaaa
Joined
Aug 14, 2019
Messages
6
Reaction score
3
Age
28
Can we assume that a proper compass calibration did not fix the issue? If the aircraft was any where near the car speakers, that would be the reason, since they contain large magnets. It could also be related to your takeoff point. You should not take off any where close to any metallic objects. If the issue persists after a calibration away from anything metallic, and a takeoff spot also away from anything metallic, then that would confirm the magnetism effect. In that instance I would suggest a degauss with a device called C-Fixer. See this link: Degausser
Calibration does not help. Thanks for the tips. I ordered this device with express delivery. I'm waiting, I will write if this helps me. Thank you
 
  • Like
Reactions: RodPad
Joined
Aug 14, 2019
Messages
6
Reaction score
3
Age
28
@Milaaa,

If you have done what @Fly Dawg has suggested and still got issues, It sounds a lot like most of the posts.

Here are some threads about C-Fixer

If you locate the section in the app, in the IMU calibration area, not sure on a P4's you can view your compass data, I assume if you got numbers then the compass is functioning.

If there are all zeroes then the compass is not repairable or disconnected?
If I'm incorrect on the last sentence somebody chime in....

Rod
thank. studying these posts. I ordered the device. I’m waiting

Compasses in the red zone. Calibration doesn't help
 
  • Like
Reactions: RodPad

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
Yeah, let us know!

Rod
 
Joined
Aug 14, 2019
Messages
6
Reaction score
3
Age
28
Hum, two compass's on a P4.. ;)

Rod
Hey. I got a package with my device. It helped fix my problem. That's cool. Thanks for the advice.
aYhBwVim8nU.jpg
 
  • Like
Reactions: RodPad

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
Thanks, so many never share there results.

thumb-up-terminator pablo M R.jpg

Rod
 

New Threads

Forum statistics

Threads
135,463
Messages
1,401,548
Members
98,664
Latest member
TX Baron